The requirements of Plattar Apps are similar to modern 3D games, which require a good amount of horsepower for a smooth experience.

Markerless

Markerless experiences are the new norm for Augmented Reality which require devices to meet certain minimum standards.

Apple ARKit
Users will need to have a device from this list and be updated to the latest iOS version to be able to access Apple's ARKit. 

We also recommend that if you are using your app at event, that having an iPhone 8, iPhone X or iPad Pro will provide the best result.

Google ARCore
Users will need to have a device from this Google list to be able to access Google's ARCore. 

Trigger/Marker Based

The below requirements are for devices using a trigger/marker based experience.

Minimum operating system version:

  • iOS 10 and up
  • Android 5.0 and up

Minumum Hardware:

  • 1GB RAM
  • 1Ghz+ CPU with 2+ cores

As an example, most non-budget smartphones made after 2014 (such as the Samsung Galaxy S4 or iPhone 5S) will run Plattar at an acceptable framerate. Flagship phones made after 2015 will be able to run at maximum speed and quality.

Incompatible Devices

Other than the above mentioned specifications, in some cases WebGL is disabled by Google due to poor quality drivers from the device manufacturer. Generally this issue only affects a small percentage of generic Android devices.

The incompatibility is determined by 3 factors: the model of device, its chipset, and the android version. 

For example the Galaxy S6 has one chipset in the US and another internationally. Across those phones, 6/7 different versions of android may be in use.

Even if a specific combination of model, chipset and android version does not work, other combinations may not have any issues.

A list of incompatible device, chipset and android combinations can be found here: http://opengles.gpuinfo.org/gles_listreports.php?extensionunsupported=GL_EXT_robustness

Did this answer your question?